升级WordPress 5.8导致小工具无法使用

发现WordPress 5.8更新后,默认使用古腾堡编辑器管理后台的小部件。一些旧的主题可能会导致兼容性问题,这可能会导致页面无法打开或在设置小部件时屏幕空白。

想要要解决这个问题,你可以将小工具切换回经典模式。经典小部件是一个只需要安装和激活的WordPress插件。

https://wordpress.org/plugins/classic-widgets/

Classic Widgets 是由 WordPress 团队维护的官方插件,用于恢复以前(“经典”)WordPress 小部件设置屏幕。它将至少支持和维护到 2022 年,或者只要有必要。

激活后,此插件会恢复以前的小部件设置屏幕并禁用块编辑器管理小部件。没有其他配置,通过启用或禁用此插件来启用或禁用经典小部件设置屏幕。

不过也可以使用代码的方式解决两行就OK!

add_filter( 'gutenberg_use_widgets_block_editor', '__return_false' );
add_filter( 'use_widgets_block_editor', '__return_false' );

 

版权声明:
作者:小和Fun
链接:https://www.xhfun.cn/wp5_8toolerror.html
来源:小和Fun
文章版权归作者所有,未经允许请勿转载。

THE END
分享
二维码
打赏
< <上一篇
下一篇>>
文章目录
关闭
目 录